Openfire
  1. Openfire
  2. OF-8

The owner retrieving items for a pubsub node should not require a subscription id when there is only 1 subscription

    Details

    • Type: Bug Bug
    • Status: Open
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: 3.9.1
    • Fix Version/s: None
    • Component/s: PubSub
    • Labels:
      None

      Description

      Attempting to retrieve items for a node will fail when there was no subscription id specifed in the request, even though the user only has 1 subscription. This should work if there are not multiple subscriptions.

      This occurs for the owner only after creating the node, since they are automatically subscribed when the node is created. This appears to be a defect, since there is nothing in the spec to support this behaviour.

        Activity

        Hide
        Daryl Herzmann added a comment -

        Robin, Is this issue still valid? Just attempting to clean up tickets today...

        Show
        Daryl Herzmann added a comment - Robin, Is this issue still valid? Just attempting to clean up tickets today...
        Hide
        Daryl Herzmann added a comment -

        Hi Robin, any comments?

        Show
        Daryl Herzmann added a comment - Hi Robin, any comments?
        Hide
        Robin Collier added a comment -

        Still valid to my knowledge.

        Show
        Robin Collier added a comment - Still valid to my knowledge.

          People

          • Assignee:
            Tom Evans
            Reporter:
            Robin Collier
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:

              Development